Help Center/Knowledge Base Access Failing

Incident Report for TalentGuard Status Page

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 20:14 CDT

Investigating

We are investigating an issue with customers not able to access the Help Center and our Knowledge Base.
Posted Aug 24, 2026 - 14:26 CDT
This incident affected: Infrastructure (Zendesk (Help Center and Knowledge Base)).