We have identified the root of this issue and we are making multiple code improvements. Extensive testing on the code is required to ensure a quality deployment and improved experience for all of our clients. There is currently no ETA on the deployment of this code, however it will be deployed as soon as testing is completed.
As a reminder: this is only affecting some of our US-based clients currently on server "TMS".
Posted Jul 16, 2025 - 11:44 CDT
Investigating
We are investigating various performance issues impacting some of our U.S. clients in the morning, such as slow user import processing, server errors, and issues with End-User Assist, among others.
We have identified the possible root cause as part of a nightly maintenance routine that is performed on our servers. This particular process handles various tasks, including HRIS integration tasks, Performance Review tasks (e.g, binding review reports to users), and many others. This process is running longer than expected and affecting the application's response and behavior.
Our engineering team is actively working to resolve these issues. Please subscribe to this incident for updates. Thank you for your patience.
Posted Jul 03, 2025 - 13:01 CDT
This incident affects: TalentGuard Modules (Administrative Function, Users and Teams).